Cloud provider issue

Incident Report for Veo

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 22:52 CEST

Identified

Veo is currently unavailable due to an outage affecting our cloud provider. They are aware of the issue and actively investigating. We are monitoring the situation closely and will provide updates as soon as more information becomes available.
Posted Sep 16, 2025 - 21:27 CEST
This incident affected: Web applications (Web application (app.veo.co), Player profile (profile.veo.co), League Exchange) and Mobile applications (Live app, Veo Go app).