Player and Team Images Not Displaying on web and mobile apps

Incident Report for Veo

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 16:18 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 15:33 CET

Investigating

We are investigating an issue causing player and team images to not display on our web and mobile applications (VeoGo, Live). The issue affects image visibility only; core functionality is not impacted.
Posted Jan 28, 2026 - 14:37 CET
This incident affected: Web applications (Web application (app.veo.co), Player profile (profile.veo.co)) and Mobile applications (Live app, Veo Go app).