Veo Go app not compatible with iPhone 17 series

Incident Report for Veo

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 12:35 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2025 - 11:09 CEST

Identified

We’ve identified that the current app version on Veo Go does not support the new iPhone 17 series. A fix is currently underway, and an update will be released shortly to restore full compatibility.
Posted Sep 23, 2025 - 17:03 CEST
This incident affected: Mobile applications (Veo Go app).