Access Issues on Safari (iOS 26, iPadOS 26, macOS Tahoe)

Incident Report for Veo

Resolved

We have fixed the login on safari 26 for mobile and desktop
Posted Sep 16, 2025 - 18:48 CEST

Investigating

We’ve identified an issue preventing some Safari users from accessing app.veo.co.

As a workaround, please enable Advanced Tracking and Fingerprinting Protection in Safari settings (under Advanced).
We are continuing to investigate and will provide updates as we work toward a permanent fix.
Posted Sep 16, 2025 - 10:31 CEST
This incident affected: Web applications (Web application (app.veo.co)).