Recordings not uploading

Incident Report for Veo

Monitoring

We've built a fix and deployed a new 3.5.1 firmware to affected VC2 & VC3 cameras. We will monitor the situation over the weekend.
Posted Apr 11, 2025 - 16:33 CEST

Identified

We've identified an issue with the 3.5.0 firmware. If the camera runs out of battery while recording, the video will not be able to upload properly. We are working on a fix and will deploy a 3.5.1 shortly.
Posted Apr 10, 2025 - 14:31 CEST
This incident affects: Camera.