Veo Go highlight reel not available in the Veo Go app

Incident Report for Veo

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 11:23 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 14, 2025 - 11:18 CEST

Investigating

We are currently investigating the issue.
Posted Jul 14, 2025 - 10:34 CEST
This incident affected: Veo Go.