Degraded upload performance in Veo Go

Incident Report for Veo

Monitoring

Version 1.5.3 has been released now. Please update to version 1.5.3 from the App Store, and then you can cancel a stuck upload and restart it.
Posted Sep 30, 2025 - 20:35 CEST

Update

We are aware of an issue where uploads may get stuck and not complete.

What you should do:
• Do not delete the app – this is important to ensure your recordings remain safe.
• Please wait for the upcoming app version that will resolve this issue.
• Once the new version is released, after updating the app through App Store, you will be able to cancel the current stuck upload and start the upload again.

We will update this page as soon as the new version is released. Thank you for your patience.
Posted Sep 29, 2025 - 11:29 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 28, 2025 - 15:08 CEST
This incident affects: Mobile applications (Veo Go app).