Login and app errors, delayed recording delivery

Incident Report for Veo

Monitoring

The system has stabilized. Logins and recording delivery are recovering, and we're monitoring closely.
Posted Sep 13, 2026 - 22:42 CEST

Investigating

We're investigating errors and login failures in the Veo app, plus delays in recording and highlight delivery.
Posted Sep 13, 2026 - 22:09 CEST
This incident affects: Web applications (Web application (app.veo.co), League Exchange) and Core services (Authentication service, Uploading recordings, Processing & delivery).