Uploading and live streaming broken

Incident Report for Veo

Resolved

Uploads and live streaming are working normally again

Between 13:25 and 16:15 EDT (17:25–20:15 UTC) on Sunday 27 September, many uploads and live streams failed to start.

We know many of you were recording or streaming games that matter, and some of those moments may have been missed by players, coaches, and families watching from home.

We're truly sorry.

The cause was a few scaling issues multiplying under peak Sunday load. We've identified and fixed it, and we're making further improvements over the next few days so it doesn't happen again.

Thank you for your patience, and again, we're sorry for the disruption. We will be ready for next weekends match!
Posted Sep 27, 2026 - 23:44 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2026 - 23:18 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 27, 2026 - 22:23 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 27, 2026 - 22:22 CEST
This incident affected: Core services (Uploading recordings).